toggle menu

Настройка MikroTik CAPsMAN для RouterOS v6.40

8

Пошаговая настройка бесшовного роуминга CAPsMAN для MikroTik RouterOS v6.40

Настройка основного маршрутизатора

Интерфейс MikroTik bridgeCAP

В меню Bridge создайте новый bridgeCAP

name=bridgeCAP

nastroika-mikrotik-capsman-ntema1.jpg (114 KB)

Настройка канала MikroTik CAPs

Выберите в меню CAPsMAN — Channel и задайте параметры:

name=hs-channel1
frequency=2457
control-channel-width=20
band=2ghz-b/g/n
tx-power=20
nastroika-mikrotik-capsman-ntema2.jpg (90 KB)

Mikrotik CAPs datapath

Затем настройте datapath:

bridge=hs-bridge
name=hs-datapath1
client-to-client-forwarding=yes

nastroika-mikrotik-capsman-ntema3.jpg (70 KB)

Mikrotik CAPs Configuration Wireless

Далее configuration.

Вкладка wireless:

name=hs-cfg1
mode=ap
ssid=WiFi-CAPs
rx-chains=0,1,2
tx-chains=0,1,2

nastroika-mikrotik-capsman-ntema4.jpg (98 KB)


Mikrotik CAPs Configuration Channel

Вкладка channel:

channel=hs-channel1

nastroika-mikrotik-capsman-ntema5.jpg (90 KB)

 

Mikrotik CAPs Configuration Datapath

Вкладка datapath:

datapath=hs-datapath1
nastroika-mikrotik-capsman-ntema6.jpg (93 KB)

Mikrotik CAPs Manager

Далее CAP InterfaceManager:

Поставьте галочку enabled

enabled=yes
nastroika-mikrotik-capsman-ntema7.jpg (91 KB)

Mikrotik CAPs provisioning

Вкладка provisioning:

action=create-dynamic-enabled
master-configuration=hs-cfg1
nastroika-mikrotik-capsman-ntema8.jpg (99 KB)

Mikrotik Wirless - CAP

Теперь в главном меню выберите Wirless - CAP:

enabled=yes
interfaces=wlan1
discovery-interface=bridgeCAP
bridge=none
nastroika-mikrotik-capsman-ntema9.jpg (111 KB)

Настройка дополнительных устройств MikroTik

Mikrotik bridge

Создайте бридж:

name=hs-bridge

nastroika-mikrotik-capsman-ntema10.jpg (60 KB)

Добавьте в него LAN порты устройства MikroTik:
nastroika-mikrotik-capsman-ntema11-1.jpg (70 KB)

Mikrotik DNS

Зайдите в IP - DNS:

servers=8.8.8.8,208.67.222.222
allow-remote-requests=yes

nastroika-mikrotik-capsman-ntema12.jpg (59 KB)

Mikrotik IP — DHCP Client

Вкладка DHCP Client:

interface=hs-bridge

nastroika-mikrotik-capsman-ntema13.jpg (75 KB)

Mikrotik IP — DHCP Client Advanced

Вкладка Advanced:

dhcp-options=hostname,clientid

nastroika-mikrotik-capsman-ntema14.jpg (75 KB)

MikroTik Wirless - CAP

Меню Wirless - CAP:

enabled=yes
interfaces=wlan1
discovery-interfaces=hs-bridge

nastroika-mikrotik-capsman-ntema15.jpg (78 KB)

Настройка MikroTik CAPsMAN готовым скриптом

Всё вышеперечисленное настраивается намного быстрее, если использовать готовые скрипты. Достаточно вставить скрипт в терминал нужного устройства MikroTik.

Основной маршрутизатор:

/interface bridge add name=bridgeCAP
/caps-man channel add band=2ghz-b/g/n frequency=2457 name=hs-channel1 tx-power=20 control-channel-width=20
/caps-man datapath add bridge=hs-bridge name=hs-datapath1 client-to-client-forwarding=yes
/caps-man configuration add channel=hs-channel1 datapath=hs-datapath1 mode=ap name=hs-cfg1 rx-chains=0,1,2 tx-chains=0,1,2 ssid=WiFi-CAPs
/caps-man manager set enabled=yes
/caps-man provisioning add action=create-dynamic-enabled master-configuration=hs-cfg1
/interface wireless cap set enabled=yes interfaces=wlan1 discovery-interface=bridgeCAP bridge=none

2-й, 3-й, 4-й, 5-й ... маршрутизатор:

/ip dns set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222
/interface bridge add name=hs-bridge
/ip dhcp-client add dhcp-options=hostname,clientid disabled=no interface=hs-bridge
/interface wireless cap set discovery-interfaces=hs-bridge enabled=yes interfaces=wlan1
/interface bridge port add bridge=hs-bridge interface=ether1
/interface bridge port add bridge=hs-bridge interface=ether2
/interface bridge port add bridge=hs-bridge interface=ether3

/interface bridge port add bridge=hs-bridge interface=ether4
/interface bridge port add bridge=hs-bridge interface=ether5


Оставьте свой комментарий